Readme

Collapse
No announcement yet.

DA integra swap to B18b trouble?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DA integra swap to B18b trouble?

    Alright, I have a 91 integra ls with a swapped motor witch is a 96 ls B18B. The car alredy had the motor in it when i bought it. The first problem i had was the car cutting out, so i searched and found out the retard had a b16a ecu in it and so i swapped the b16 ecu for a PR4 DA ecu and the car ran alot better. About a week later it kept not wanting to start due to a loose battery cable. Fixed the cable and just replaced it. A day or so later the battery died, so i had to charge it and put it back in the next day it died again. So i went and bought a new battery and later on that battery died which would indicate the alternator. Well i replaced it with a new one and then i get all hell! The headlights flash and wont stay on and when you turn them on the tach on the car bounces around. The battery wont hold a charge or the alternator wont charge it. Eventually, the car dies. When it is running it runs like it is rich or needs tuned bad but only seems to act up when driving not idleing. There was also the negative wire on the battery that went down to the transmission where it is screwed down was loose, i tightened it and am still having the same problems. what would cause all this. Could it be the switching of the ecu's or needs tuning or a wire short? I have done all that i can think of and am going to go read through the haynes manual to think of ideas. Any help would be appritiated, Thanks

  • #2
    did you check the ground to the thermostat housing as well?

    Comment


    • #3
      No, i didnt i will do that soon as i get home. But you think it not being properly grounded would cause that much trouble?

      Comment


      • #4
        it has been responsible for similar symptoms on the g3 I had. the speedometer and tach would bouce around, lights would go on and off. it was a little loose though not all the way off. if that ground is all the way off you'll get nothing when you try to start it

        Comment


        • #5
          Thats what i get now is nothing. I think its because the battery is dead thought. But for some reason the alternator is not charging it when i jump it. Soon as i jump the car it starts and runs fine until like after a minute then you turn the lights on and they flicker and tach bounces then the car eventually dies.

          Comment


          • #6
            I will check the ground to the thermostat though to be sure, cause i know that the guy i bought the car from, had a shop install the motor swap and the wires are cut all over the place, hoses, and everything else.

            Comment


            • #7
              I checked the thermostat housing and the ground is tight. What else could it be?

              Comment


              • #8
                bump come on people someone help me please.

                Comment


                • #9

                  Comment


                  • #10
                    I did the same swap and I am running on all the 91 Integra parts but I used a 96 B18B block and head, fuel rail(obd1), fuel pressure regulator(obd1). I am running a pr4 Obd0 ecu and all the other Obd0 parts like cap and wires. I replaced the theromstat, belts, and had a valve adjustment all new gaskets.
                    another Idea might be on the intake manifold or TB since there might be a hose loose or not holding pressure.

                    Comment


                    • #11
                      Here is a video of the motor running after it finally starts. If you look carefully you can see the tach bouncing some. At the end the motor died and i did not turn it off. I dont know if it will help becayse it is a crappy video but i tried!

                      http://s97.photobucket.com/albums/l2...t=MOV00577.flv

                      soon as you start it, it will run for about a minute then die like in the video

                      Comment


                      • #12
                        hey Seth does it still make that high pitched wining noise when ever u rev it up?

                        Comment


                        • #13
                          ya that sounds like a super charger?

                          Comment


                          • #14
                            thanks for all your help guys but we figured it out...

                            Comment


                            • #15
                              What was it I have the same issue??????

                              Comment

                              Working...
                              X