Readme

Collapse
No announcement yet.

Clutch pedal/cable makes grinding sound/crunchy feeling when engine cold

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Clutch pedal/cable makes grinding sound/crunchy feeling when engine cold

    Not sure where it's coming from(pedal, bracket, shifter fork?), but when the car is cold, like when I start the car in the morning, when pressing the clutch pedal in I get a crunchy feeling, and sound. What do you think it could be? Just had the clutch cable replaced.

  • #2
    Anyone?

    Comment


    • #3
      Did you put the cable threw a little hole in the fire wall that aligns it to the hook on the pedal. If not it might be misaligned and causing it to grind somewhere in the fire wall.

      Comment


      • #4
        I'll double check, but i'm sure it went in correctly. Coincidentally, I had to tighten the cable a couple of times since installation.

        Comment


        • #5
          Did you ever find out what it was? Mine is doing the same thing - but now the pedal is releasing slowly and "popping" back up at me. TIA

          Comment


          • #6
            Originally posted by bayjay View Post
            Did you ever find out what it was? Mine is doing the same thing - but now the pedal is releasing slowly and "popping" back up at me. TIA
            I did. The cable broke like 2 weeks later. Replaced it and the clutch/pressure plate. All good now!

            Comment

            Working...
            X