Readme

Collapse
No announcement yet.

Automatic Cold Weather Fix! (neutral safety switch can't shift out of park key stuck)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Automatic Cold Weather Fix! (neutral safety switch can't shift out of park key stuck)

    I've had two automatic Tegs in my life, 90LS and a 92GS both had the same problem in the winter time...

    Wake up early in the morning and get the car all warmed up for my trip to work and/or school. I pull into parking lot and throw the shifter into "P" park and WHAT?!?! no little red light on the dash? but i know its in park! So i turn the car off and try to pull the key out.. BUT I CAN'T! WTF! Lord Why? so i sit there and sit there... (one day i sat in the parking lot waiting to pull my keys out for 20min, unreal!). Some days i just left the Frack'n keys in the car and said, "if you can take the car out of park you welcome to it." No matter what you do you can't take the keys out or take it out of park. But there is a fix!



    There are two parts you have to replace, #4 (far right) and #36 (middle). I replaced both parts, but someone told me you can do it by just replacing #4 i guess... but i hate waiting 20min in a parking lot waiting for my keys so i replaced both. It also seems the colder the weather the longer you have to weight. Hope this helps us winter weather guys out.

  • #2
    Is there any reasoning behind the replacement?
    NEIL B. - 1991 DA945. Owner since 1997.
    ANYONE CAN BUY A NEW CAR. IT TAKES A TRUE ENTHUSIAST TO BREATHE LIFE INTO AN OLDER ONE.

    SUPPORT G2IC BY VISITING THE G2IC STORE TO GET OFFICIAL G2IC CLOTHING AND DECALS

    Comment


    • #3
      I was unable to come up with a firm reason behind why this happens, but i do have a theory. When its cold out the water vapor in the freezes (dah) and collects on your winshield and other objects. since the shifter is at the bottom of the car and heat raises that its more likely to freeze up the electrical connects for the shift lock and the sensor that reads where the shifter is. Over time this could cause damage to wiring and other electrical componets, but i have no clue and its strickly a theory. Never the less, i replaced both parts and in cold weather i have yet to have a problem. To bad i didn't find it out at the beginning of winter. Another possible solution maybe to simply clean it, but with what i don't know... since most cleaners are comprised of water and would only add to the problem. If anyone has any insights into this problem i would love to hear it, but like i said, i have no clue why it happens in cold weather.

      Comment


      • #4
        i took mine apart and cleaned it and scrubbed the contacts shiny. i also regreased it with dieelectric grease. the old stuff was very black and grimy. i couldnt conclude whether or not it helped because it happened so randomly and ive since converted to manual. i took pics ill try to get them up.
        autozone online repair manual
        http://www.autozone.com/addVehicleId...leSelected.htm

        supplement with haynes manual from pep boys (<$15). includes vital troubleshooting and maintenence schedules.

        pics of all gsr rims

        b-series dynos

        Comment


        • #5
          its called a neutral safety switch

          Comment


          • #6
            Hey guys.

            I have the exact same problem. It gets very cold up here. In winter the avg temperature is below freezing all the time. I know this problem very well. Couldn't find any solution and every mechanic i saw thought that it was my transmission. Recently I had my tranny replaced. But again the same freaking problem at night if its cold. thanks for the post.. Can anyone tell how to replace it? What will i need for that.. post with pix will be awesome

            Thanks again..

            mo.

            Comment


            • #7
              TECHNICAL SERVICE BULLETIN
              A/T WON'T SHIFT OUT OF PARK
              Model(s): 1990-93 Acura Integra
              Group: Transaxle
              Bulletin No.: ASN 0695-02
              Date: June, 1995

              SERVICE INFORMATION
              A shift-interlock-equipped car that won't shift out of Park may have
              a bad throttle position (TP) sensor. Measure the TP sensor voltage at
              idle (refer to section 11 of the appropriate S/M); it should be 0.5 V
              (0.3 V for 1990-93 Integras). If the TP sensor voltage is 0.7 V (0.55
              V for 1990-93 Integras) or more, the shift interlock system won't let
              you shift the transmission out of Park. If the TP sensor is at fault,
              replace the throttle body.

              Comment


              • #8
                I replaced the TB same thing still happens.

                Comment


                • #9
                  Is it neutal safty switch or
                  "If the TP sensor is at fault, replace the throttle body."

                  Guyz, now I'm really confused. Tonight its gonna be 33F. I just waited in my car for 2 minutes until the "P" light turned on. Its getting worst as its getting colder. I was gonna be late for my class today.
                  How much is it going to cost? One more thing. I live in a small town, mechanics here have never seen a fancy car like ours
                  What am I suppose to tell them? I don't wanna get ripped off by some Asshole.

                  Thanks for the helps Though

                  Comment


                  • #10
                    The throttle body is way expensive (over 300 I think), so I would try other stuff first if it were my choice.

                    Where in upstate ny are you?

                    Comment


                    • #11
                      I thought it was maybe the SOLENOID ASSY. #9

                      Comment


                      • #12
                        I'm at Plattsburgh, very close to Canadian border. Montreal is like an hour drive from here.

                        I am not sure if i will be able to spend 300 bucks, but the fact is that the problem is very very annoying. It just burns my gas for no reason. All of us know how we are paying more and more each day for gas.

                        Comment


                        • #13
                          thank you so much for the tip. I have been getting really pissed off when it gets cold out. When I get some money I am going to get those parts and fix the problem once and for all

                          Edit:I just replaced the part #4, i sent to article with picts to the tegtips link and hopefully it will be up later.
                          Last edited by karnieflk; 14 Oct 2004, 21:46:55. Reason: more info

                          Comment


                          • #14
                            wanted to bring this topic back up. i've been having this issue for a few years now. never really cared too much, but i figure i might as well take care of it now.
                            since your pics don't work, can you give an explanation of what to replace and how to replace it? time involved and ballpark range of price. thanks

                            -jeff

                            Comment


                            • #15
                              just take out the gear selector switch, take it apart, clean it really good, then take the contacts out of it and stretch the springs in the slider. then use some dielectric grease and you are good to go. total cost ? $0.99+tax

                              Comment

                              Working...
                              X