Results 1 to 15 of 15

Thread: engine? knocking on acceleration.

  1. #1
    corona

    engine? knocking on acceleration.


    from the threads i came up with while searching, it seemed like oil was somehow the problem? i never found a really clear question & answer though.

    i get a knocking sound from the frontend of my car...sounds like it's from the engine. but it doesn't sound like metal on metal...and it's not really harsh at all. the times i hear it are when i'm accelerating, usually been 2000 and 4000 rpms....typically in 2nd and 3rd gear. i've heard it a few times in first...but it's rare.

    the sound started about a week ago. (i've never had it before)
    happens when it's warm and cold.
    it speeds up as the rpms go up/i go faster.
    it doesn't happen when i'm not in gear. (it just purrs like it usually does)
    and it doesn't happen when i'm maintaining a constant speed/rpm.

    last time i changed my oil was about 3000 miles ago. (i want to do it now, but i just don't have the time or means at all)

    help's appreciated,
    thanks!

  2. #2
    G2IC Premier Member
    Join Date
    29 Nov 2001
    Location
    Irving, TX
    use your hand for the throttle at the TB and listen with the car running and hood open,

    if you cannot find it that way get an extra ear/hand from a friend... could be ANYTHING..

  3. #3
    corona
    what am i supposed to listen for?

    i did what you suggested today - but i couldn't hear any knocking whatsoever.

    the only two explanations i could think of would be it needing a valve adjustment. but why wouldn't it knock when the gears aren't engaged?
    or having something wrong with my front axle. (i've been doing a good deal of dirt road driving lately)

    i don't have the money to throw away getting it examined at a dealer/shop....so i'd like to narrow down the problem and see if i can't pinpoint it, so they know exactly what to fix/do if i take it in.

    edit...went to the grocery store this afternoon - and i'm pretty convinced that it's a axle/suspension problem, and not an engine one. it knocks faster as i speed up...and that knocking isn't really associated with the rpms.

    problem is...it's definately gotten louder. :/
    ATTENTION! This post has been edited from its original contents. You may want to check the message again to make sure no discrepancies occur that may adversely affect you.
    Last edited by corona : 20 Jan 2005 at 00:50:05

  4. #4
    Rjohn730
    Really sounds like axle from your description.

  5. #5

    Join Date
    26 May 2003
    Location
    Fairfax, Virginia, USA
    Quote Originally Posted by corona
    but why wouldn't it knock when the gears aren't engaged?:/
    I realize you believe it is your suspension, but just to answer this question... Engine noise may not show up in neutral because the engine is not under a "load". 3000rpm sitting in your driveway is alot different than 3000rpm going up a hill or accelerating.

    Anyway, about your suspension: Have you inspected your CV boots on your axles? If they are cracked and leaking you may have ruined the joints. Wheel bearings are also a remote possibility.

  6. #6

    Join Date
    09 Oct 2003
    Location
    Peoples Republic of Kalifornia
    Yeah sounds like an axle. One of mine is doing the same thing. Shitty thing is I just replaced both of them a few months ago cause one was bad giving out a vibration. I am not sure which one it is. But it's doign the same thing. And when I turn the wheel to either side, it goes away.

  7. #7

    Join Date
    27 Jan 2004
    Location
    Orange County, California
    Corona, knocking under load maybe a sign of bad gas. Try a tank of premium.

    It can also be from having your timing too far advanced.
    ATTENTION! This post has been edited from its original contents. You may want to check the message again to make sure no discrepancies occur that may adversely affect you.
    Last edited by Archon : 20 Jan 2005 at 20:46:44

  8. #8

    Join Date
    30 Jun 2004
    Location
    Back in the PacificNW!
    Quote Originally Posted by corona
    last time i changed my oil was about 3000 miles ago. (i want to do it now, but i just don't have the time or means at all)
    Don't you have any quick lube shops in your town? Like Oil can henry's, jiffy lube, and so on...if you aren't running synthetic, it should only be like 20 bucks for new oil+filter. Atleast that's how it is around here.

    Yeah, and i'm going to vote on it being an axle.

  9. #9

    Join Date
    27 Jan 2004
    Location
    Orange County, California
    3,000 mile oil change intervals (OCI) was created by oil companies and quick lube places out of greed and profit chasing rather than need.

  10. #10
    B00BAA
    Check your tires, they may be scolloped (concave wear) on the inner side of tire [not the wall of tire] This causes the knocking- does you're steering wheel shudder also, and the engine feel like its broken its mounts? If so check the tires- plus its good place to start, tyres- then rims- then suspension- then driveline etc etc till you find the problem. let us know how it goes

  11. #11
    corona
    thanks for all the replies.

    i think i'm running a castrol synthetic right now. (though i'd have to get the bottle to be 100% sure) - but i'll probably take it in somewhere to get that changed soon.

    i just did a bunch of circles in a nearby parking lot this afternoon...and there was no knocking. i was under the impression that if it knocked doing 360's, that's what means the CV boots are bad....not when going in a straight light.
    so that may be out.

    it seems to go away in corners too. (so for instance, if i'm taking a hard left hand turn, the sound won't start knocking until the wheel's back to almost straight)

    and the steering wheel doesn't shudder/shake at all. and my tires (winter ones) only have a few thousand miles on them...if that.

    also...if it is the axle, can i do anymore damage by driving on it? and it won't fall off or anything, will it? lol
    and what kind of price am i looking at to get it replaced?

  12. #12
    blk&cromeG2
    check your upper control arms.....it may not be the axle due to the fact that it stops on certain maneuver,when my control arms went i was getting the same behavior from my teg.let us know what happen.
    edit:also jack the front of the car up and put one hand on the bottom of the wheel and one hand on top and try and shake the wheels if they move snatch those control arms out ASAP!!.good luck

  13. #13
    DA9Skater
    man i had a similar problem. mine was knocking when iw as on a highway race goin like 110 then i heard the knock consistantly for a minute or 2. this was a one time occurence and when i slowed down to about 80 it stopped, i dont think what ppl said in here can help me , good luck to ya

  14. #14
    corona
    Quote Originally Posted by blk&cromeG2
    check your upper control arms.....it may not be the axle due to the fact that it stops on certain maneuver,when my control arms went i was getting the same behavior from my teg.let us know what happen.
    edit:also jack the front of the car up and put one hand on the bottom of the wheel and one hand on top and try and shake the wheels if they move snatch those control arms out ASAP!!.good luck
    thanks.....what was the matter with the upper control arms? i wasn't aware that they could just die? did that rubber balljoint just wear out and get loose?

    Quote Originally Posted by DA9Skater
    man i had a similar problem. mine was knocking when iw as on a highway race goin like 110 then i heard the knock consistantly for a minute or 2. this was a one time occurence and when i slowed down to about 80 it stopped, i dont think what ppl said in here can help me , good luck to ya
    i can help you.
    don't go 110 on the highway. lol

  15. #15
    DA9Skater
    Quote Originally Posted by corona
    thanks.....what was the matter with the upper control arms? i wasn't aware that they could just die? did that rubber balljoint just wear out and get loose?


    i can help you.
    don't go 110 on the highway. lol
    that dont help much cuz i've gone 125ish hella before and nothing happened

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •