Results 1 to 13 of 13

Thread: hazard lights work but turn signals don't?

  1. #1
    92integ4u2nv

    hazard lights work but turn signals don't?

    my hazard lights work in my car but when i turn the signal lights on they dont work. i was thinking it was the flasher but someone told me that the flasher works for both hazard and turn signals. i checked all fuses and wires and i cant figure this out. has anyone else had this problem before?

  2. #2
    G2Toronto
    check your fuse under the steering colum or under the hood.

  3. #3
    92integ4u2nv
    i checked all fuses and wiring. still no go. someone please help me!!!!!!!!

  4. #4
    zammer

    hey

    gauranteed your blinker relay's burt out for your blinkers but not for your hazards. go to the fuze box the turn on your hazards the black one inch squared box that isn't going click click is your blinker box... replace it... 5$

  5. #5
    2067739
    Does anyone have pics of where this relay is located?
    I'm having this same problem where my bumper signals work, but not my corner turn signals...

  6. #6
    stateofbean
    (damn you brought an olllllllld thread back hehe)

    Are you running USDM or JDM headlamps? If you're using the JDM ones, you probably used the wrong set of sockets for the corner lamps. If you're using USDM ones and *both* bulbs on both sides stay lit w/parking lights (there's 2 on each side, not 1.. if you only see 1 then you have a burnt out bulb) then your integrated control unit is dead.

    When that relay goes out, the turn signals are totally dead. No bumper lights, no corner lights flashing, nothing. (same thing happens if your backup light fuse blows)

  7. #7
    2067739
    Quote Originally Posted by stateofbean
    (damn you brought an olllllllld thread back hehe)
    Figured it's the best way to show that I searched on the subject

    I have a USDM setup. The blinker light in the corner assembly on both sides do nothing. The running lights in the corners work fine and my bumper blinkers work fine, but corner blinkers haven't worked since I bought car a few months ago. Bulbs were fine last time I checked them. So is this a integrated unit problem? Where is it at? Do I also understand that if the relay was shot, that I wouldn't have working bumper blinkers either? I hope I can get this fixed soon, I'd really like my corner blinkers to do something besides take up space...

  8. #8
    stateofbean
    Good point Do /both/ corner lights (including the turn signal one) light up with the parking lights? Normally they should, even if there's a problem with the ICU (they just stop blinking when the ICU dies). If not, get a multimeter and check for voltage at the sockets and also back-probe the wires going into the socket, you should be getting battery voltage with the parking lights on. You'll need to remove the corner lens assembly to easily access the wires though.

    If you're getting no voltage, then there's more than likely a problem elsewhere. If you /really/ want them to work (the ICU is a bitch to replace), it'd probably be easier to run new wires to the sockets - splice 1 into the + wire on the other corner lamp, and the other into the + wire on the bumper light socket. Result is they stay lit with the parking lights, and blink with the turn signals, exactly as they do from the factory. I wouldn't bother replacing the ICU unless other functions it controls - intermittent wipers, seat belt beeper, "key in" reminder, rear window defroster, etc stop working or don't work properly. On mine the key in reminder and intermittent wipers do nothing

  9. #9
    stateofbean
    Oh yeah.. ICU is behind the fuse box. Have to remove the drivers side kick panel and the fuse box to get to it... real pain in the ass, and a junkyard one is just as likely to be dead. New one runs $150+.

    Also, even though the bulbs /look/ fine, have you swapped them with the corner lamp bulbs to be sure? 194 type bulbs can look brand new even when there's a break in the filament.

  10. #10
    2067739
    This is a lot of good info! The bulbs are now brand new and still don't work. Neither side will come on at all.

    After your description it seems I also have an ICU problem because now I'm having problems with my defroster and intermittent wipers as well. Don't know if it's worth all that money and hasle right now though.

    I think I'll just re-wire my turn signals to the bumper signals like you said, but do you have any other ideas about why they don't even turn on?

  11. #11

    Join Date
    02 May 2003
    Location
    Nor Cal, CA
    after my bro was in an accident his cars hassards isnt working!

    turn signals work but no hazzards

    totaly opposite ur problem..
    imma look at every fuse tomarro

  12. #12
    JUNGENE
    Im Also Having Problem But Not Sure If This Is Related To This Thread, When I Signal On My Left, The Right Corner Light Signals As Well. Is This An Icu Problem? I Have Check All The Fuse In The Fuse Box (all Good) And I Changed My Hazard Swithch Also Still Doing The Same Thing. Can You Also Help Me Out? Thanks,

  13. #13
    EddieGSR
    Do you have stock headlights or JDMs... b/c if you have jdms, its very easy to do this by crossing some wires...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •