No announcement yet.

Hondata S300 solid red light for 20+ mins then go's green.

  • Filter
  • Time
  • Show
Clear All
new posts

    Hondata S300 solid red light for 20+ mins then go's green.

    Hey guys, I bought a v1 Hondata s300 installed in a p28 from a friend. I also have my original P61 with a s100 installed. When the car is cold or the ECU, it takes an average of 20+ mins for the red light, visible through the USB port, to go green. At that moment, I can hear the fuel pump prime (fuel pressure guage shoots up to 38 psi) and I'm able to start the car. After the car is warmed up, and I drive it around for a little while, the green light comes on seconds after I turn the ignition on. If I let the car sit for a while, I'll have to wait longer for red light to go seems the longer the car is off, the longer it takes for the light to turn green. If I swap out the S300 equipped ECU for my P61 w/ the S100, it starts up every time, even after letting the car sleep for days!
    I've replaced and added extra grounds to and from the chassis. I've clean, added and secure the grounds on the thermostat housing. I have no other electrical issues with the car nor do I have lit engine check light. After reading this thread...I'm now thinking it may be a faulty capacitor that is not holding it's charge? Is that possible? I'm at my wits end on this one. I think I've reached the end of the Internet :/

    I had the capacitor replaced and all the pins for sockets resoldered...but I'm still having the same issue (I have to wait over 20+ mins for the solid red light on the S300 to go green after the cars is off for any length of time). My only option now is to do as suggested in a post on Hondata's forum and get a new ECU socketed for the S300.

    Note: Prior to replacing the capacitor, I took my ECU over to my friend house and connected it to his Integra, a 95 RS. When I first turned the key, there was a 2 second delay before I got the green light.
    After about 20 mins being plugged in, I removed it and brought it back home and reconnected to my DB2, and to my surprise, the damn thing went green as soon turned the key on. It seemed like the capacitor got charged up while it was plugged to my friend's car.

    Any help would be appriciated. I'm in the market for a virgin p61 pr p28.

    I would say that the ECU is bad, but the fact that it worked in another car makes me think twice. Try some other things to trouble shoot.
    -turn off datalogging and make sure the computer is not hooked up to the ECU when starting the car.
    -try a new/different car battery.
    -check/replace the main relay
    -check the ECU fuse ("spare fuse" in the engine bay fuse box) if its a 7.5A put in a 10A, if its 10A put in a 15A
    -check pins on the car side of the ECU connection. Make sure they are flush and look straight and that the wires all look good, maybe throw some dielectric grease on it.

    The ECU does not power anything, it just reads signals sent from various components, and changes things like fuel and timing to compensate for what it reads. So the fact that the fuel pump won't power up for that long makes me think it has something to do with the fuel system. If the computer isn't reading the right fuel pressure when the ignition is on then it wont allow spark, so you don't "blow up" your engine. My money is on the main relay...

    If none of these work then try a new ECU if you have the cash to throw at it or if you are any good with soldering just replace the LARGE capacitor in the ECU, that is where the problem would be.


      Thanks for all the suggestions Turbo_DB1, I'll give them a try.
      The battery is brand new and the car cranks over strong.
      The main relay...I don't have a spare but my S100 equipped P61 stars the car up fine on the 1st crank, even after days/years of being dormant.
      I'll check and replace the fuses as you suggested.
      I checked the pins previously, thinking it could have been the issue, but they are all straight and it works with the original P61. I had the large capacitor replaced already.

      Note:with S300 p28, (the ECU I'm having the issue with) I get a engine check light till the ECU goes green. I don't get any fuel pressure, till the light go green. I can actually hear the pump or the relay click on. The engine check light goes off and I can start her up.


        What kind of FPR are you running? Still think it has to do with the fuel system.

        The most important parts are:
        Fuel line - It needs to be able to hand the amount of pressure. The stock fuel line should be sufficient for high fuel pressure applications.
        Fuel Rail - Same as fuel line. The stock fuel rail should be sufficient for high fuel pressure applications.
        FPR - The regulator needs to be able to handle the extra amount of fuel that the computer is telling it to use and it needs to be in tune with the maps.
        Main Relay - The main relay could go bad and it isn't doing its job of completing the circuit to receive from fuel pressure, send to computer, read dynamics and send back to relay giving it the "green light" to prime the fuel pump.

        All of these work together and if at some point it can't read proper because one isn't allowing the "team" to work together then it will not allow things to happen as they should.

        It's almost acting as if its vapor locked. I would check the main relay, if you don't wan to buy a new one you can open it up and jump it. ***I don't recommend doing this, but it might help you trouble shoot and save some money*** Also try this before you mess with the main relay: turn the key to "on" and go to the engine bay and open up the valve on the fuel rail by pressing the pin. Be careful and use a rag to cover it so you don't spray gas everywhere. Now check to see if that changes anything. This will relive the fuel in the line and rail and hopefully tell the whole system to prime up, giving the "green light" to start.



          Thanks for all the suggestions Rob.
          The pump and lines are stock as of this moment. I do have an upgrade fuel pump waiting to be installed as soon as I can the car up on a lift to drop the gas tank.
          The fuel rail is brand new and it an AEM unit. The pressure regulator is a SARD and its also brand new.
          I have not replace the Main Relay as yet due to not having access to a spare or a loner. I'll work on getting a replacement though. Are there any specific reasons why the Main Relay would work with my original p61 ECU and not with the p28?
          Or in other words, why would it take 20+ minutes to activate with the p28 and activate instantly with the p61?

          Regarding the valve on the fuel rail...? I'm not sure if the AEM have such a valve. I didn't know the OEM one had such a valve. However, I do have a fuel pressure gauge mounted on the rail and when then key is in the on position, the gauge is dead at 0. As the light turns green, relay activates, fuel pressure on the gauge jumps to 38psi. The car then starts on the 1st crank, idles and drive just fine.
          I have 3 ECUs with me. 2 P61s and 1 P28. 1 of the P61 is socketed with a S100, the other have a S300.
          And of course the P28 also have an S300. I've swapped the S300s around between the p28 and the p61 and it didn't make a difference. The S300 p61 ECU is damage somehow. It causes the IACV to make all kinds of weird noises. It does the same thing in my friends car as well, therefore I can't use it to test with. I'm in the process of finding a virgin P28 or P61.


            With what you have said as far as your fuel system, I believe that the only way it could be the fuel system is the main relay.

            The main relay primes the capacitor in the ECU and then it gives the "green light" to charge the fuel pump. If there is a connection problem somewhere in the circuit weather it be the wiring, relay, connections or even the capacitor it wont be able to do its job right.

            Main relay - the computer worked in the donor integra so that leads us to believe that it is not the ECU or anything to do with the ECU, i.e. capacitor, S300, or any of the connections.

            Rest of the fuel system - The gauge shows that there is no pressure in the fuel system so the cold start tuning is proper because it is not waiting for the left over fuel pressure to be proper. Its waiting for something else to be ready, i.e. the capacitor.

            Capacitor - If you replaced the large capacitor in the ECU (not S300) then this is unlikely the problem, especially if it worked in the donor car. Still means that you aren't getting the proper charge to it which points to electrical and wiring.

            Based on further troubleshooting, it leads me to believe that it could be the main relay or the wiring/connections. If you can get the main relay from the donor car and put it in your car that would be great since we know they are compatible. If it solves your problem, then there you go. If it doesn't solve your problem then we can rule out the main relay. Next step would be the the wiring harness. You said you cleaned and checked all the connections to the ECU, but what about the firing harness under the dash? I know it sounds like a pain and like you said, the stock ECU works perfectly fine. Believe it or not when you add something foreign to the electrical system it can cause it to not work. For example people that add an after-market stereo after all these years and have problems or when people add aftermarket/standalone ECU. Something with the load changing and if the connection isn't perfect it just wont work.

            I'm pretty sure you can check this by disconnecting one of the battery terminals and using a multimeter between the terminal and the disconnected wire. Then if you turn the key on and all components/accessories off the only thing drawing energy should be the capacitor. Unfortunately we don't know what the capacitor should be drawing unless we do the same thing to the working donor integra to compare. Also I'm not sure the setting that the multimeter needs to be on. In theory this should work, but I'm not an expert in electrical. Lets see if we can find an electrical genius to help us out. I know there use to be one on this site a few years back. Let me see if I can find his screen name.

            As far as the wiring goes, it could be a number of things. You can check all the wiring and see what is reads with a multimeter, but we are back to not knowing what the proper reading is and what setting the multimeter needs to be on. Now that I think about it, this would be a good write up for somebody to do. It would be nice to know the proper voltage for each pin for people that are rebuilding integras, including myself. Especially since they are know for the water leakage by the ECU which can fry the ECU and corrode the harness in weird ways. Here is the pin out diagram if you care to give it a go:

            Lets start with the main relay and move from there.


              Good evening Rob... so I went across town and picked up a main relay from my friend. But now that I'm looking at the link you've posted to the eBay auctions, the relay I got from my friend is not going to work. (Part# RZ-0159). His car is a 95 RS??? I wonder if the dealer would have one in stock, I don't think I want to wait a week do one to be delivered.
              -till tomorrow.


                So Rob...2 days later...and I now have a brand new Main Relay in my possession.
                I was lucky that one (Rick Case) out of the 4 dealers that I called...HAD one in stock. ($81.00) I'll swap it out as soon as I get home and report the results here.
                Let's hope you're are right Rob. and thanks for all the help bro ^5


                  I swapped the relay and still have the same issue. I've been waiting for the past 10 mins or so, key is in the on position, CEL is lit solid and a solid red light on the P28 Hondata S300. Man, I was so hoping that it was the main relay!


                    So I went across town and borrowed another friend's P28 w/ S300. I plugged it up and got a solid green light as soon as I turned the key to th second click. I didn't start the car, but the CEL stayed on for 2 seconds and went off, with a green light lit on the S300. I then swapped my Hondata S300 module into his ECU and voila, instant green light when I turn the key to the second click and CEL light lit for 2 seconds and went off. I then started the car and let it warmed up. I then swapped back my S300 module back in to my P28, and it's back to the same old issue. A solid CEL light and a red light on the S300. I waited 20-30 mins and it finally went green and I was able to start and drive th car.
                    I may have another P28 in my hands by tomorrow along with a new S300 installation kit. I'll update as make progress or not.


                      Ok, I managed to get a virgin p28 last night. And today, got it socketed to accept my S300.
                      The issue is resolved!
                      I no longer have to wait for the red light to turn green on the s300. The car starts just fine now even on a cold start.
                      Thanks for all the help Rob. At least we have some closure on this was a bad ECU.