Readme

Collapse
No announcement yet.

Mishimot radiator

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mishimot radiator

    i purchased a moshimoto radiator witb shrout. My question is the fan bolts up on the passanger side, but on my stock radiator it was on the left and the ac fan on the right. How to connect?

  • #2
    im not exactly sure what you are asking....

    the shroud that mishimoto makes isnt for the ac. its for the regular cooling fan. you can either try and use the stock fan or buy a mishimoto fan and do what i did.

    this is how i have mine set up

    Comment


    • #3
      I got the same setup. Exept the fan that kicks on with the temperatute is the one on the driver side. The previous driver wired the fan on the right to the stereo

      Comment


      • #4
        the fan on the driver side is actually your AC Condenser fan & should also kick on simultaneously with the cooling fan. The cooling fan is far more important than the condenser fan, so I suggest you trouble shoot the wiring and test you fan switch & ECT sensor to make sure they are bot operational.

        Comment


        • #5
          Is there a way to rewire the whole radiator fan correctly? The wire harness was cut by the previous owner.

          Comment


          • #6
            Originally posted by b20DA38 View Post
            Is there a way to rewire the whole radiator fan correctly? The wire harness was cut by the previous owner.
            Yikes.. frankenwiring... serch for a wiring diagram, or if the harness is that hacked up I'd recommend nabbing a descent one from a pick-n-pull that isn't trashed...

            Ideally the cooling and condenser fans should have a black & a blue wire going to the fan plugif you can locate them they will be along the driver and passenger side and be up in the radiator area. once youy locate them test for a signal to be sent ( using a digital multimeter) when the car reaches operating temps... test the sensors listed above and also the fan switch...

            if you cannot locate both sets of wires you may want to just do as DA-All-Day suggested and run a new circuit and mount a switch in the car to turn em on manually unitl you can replace the harness or sensors.

            Comment

            Working...
            X