Readme

Collapse
No announcement yet.

battery and abs light on

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    battery and abs light on

    the other day i was on the freeway and i did what people call "power shift" (shifting to the next gear without letting go of the gas peddle). adn right after i did that my battery light came on then like 5 mins later my abs light came on. in like 20-30 mins my lights was getting hella weak my radio went off and i was losing power. does any one here know whats going on? could anyone help me out here? btw i have a 92 gsr.

    #2
    your alternator is not spinning......either cause the belt flew off or the crank pulley flew off. most likley the pulley flew off and smashed off the inside of the wheel and knocked the ABS sensor on the hub.......

    Comment


      #3
      9G, it sound like a series of unfortunate events... Not sure about the ABS sensor though, should be a lot of stuff to get into the way, unless the pulley found the ABS wire in mid-flight.

      Comment


        #4
        When you find out what parts you broke and how much it will cost you to learn that you should not do that, let us know. What did you think was going to happen? The motor was aready at a hight RPM. Did you realy think you could get it in the next gear without over-reving the motor?

        Comment


          #5
          ahhahaha
          i didnt over rev the motor i was at like 4-5 rpm when i did it and all that happend was my alternator belt went lose. i was suppose to tighten my blet a few weeks ago cuzz it started to make a noise.i ask a tech at work about it
          he said my alternatorbelt was lose. thxs for the help anyways

          Comment


            #6
            I am having the same problem with both the lights on. I know my alternator is going bad or the belt isn't tight, what-not. The abs light though it turns on with the battery light when I start my car and if I run it to over 4.5 rpms the abs light turns off and once I hit about 5 rpms the battery light will turn off, but once I drop below 5 rpms the battery light comes back on but my abs light with stay off until I turn the car off and then turn it back on again. Wtf is happening to my ride? There isn't a special code going on when the abs light and battery light turn on is there?

            Comment


              #7
              check ur alternator. all i had to do was tighten it up

              Comment


                #8
                Ooh lucky. Yea imma check mine tomorrow at work. Cuz its 250 parts and labor if I get it changed out and I don't really feel like spending that much right now on, well on this paycheck anyway.

                Comment


                  #9
                  Ok so I checked my alternator out today and everything looks good mounting-wise. The belt had jus a lil slack in it, looks like imma have to change the alternator. My ignition was hanging out from under the steering column, is it possible that the wires in the back of the ignition switch could of arched against some metal in the steering column and shorted my alternator? Or is all this jus a big coincidence

                  Comment


                    #10
                    It's your alternator. Mine did the exact same thing, battery light would come on, then shortly after the ABS light. I don't know why, but my alternator WAS the culprit. From my experience Teg alternators aren't the greatest. I had to replace them in both Tegs I had

                    Comment


                      #11
                      Jus to keep u guys posted. I changed my alternator out yesterday and everything was back to normal. No battery light (obviously) and the abs light isn't on anymore either. Weird how the abs light came on with the alternator going bad. But yea everythings coo again. Thanx guys

                      Comment


                        #12
                        I'm having the same problem in my car. The weird thing is, I just replaced the alternator about 3 months ago. I cleaned some corrosion off of my main power cable, and it went off for about an hour. I'm scared to drive it until I fix it. I am going to try to tighten the belt, anyone else have suggestions?

                        Nick AND his 90 gs

                        Comment


                          #13
                          You have a gsr right? And power shifted? Oh then that's normal. Here's the explanation....

                          Comment

                          Working...
                          X